Send Transactions are stuck for ERC20 coins and BTC

Incident Report for Rain

Resolved

Our Custodial partner has resolved the issue at their end. All stuck send transactions for ERC20 coins and BTC are now processed and completed.
Posted Mar 15, 2023 - 13:18 UTC

Update

Our custodial partners are still investigating
Posted Mar 15, 2023 - 12:58 UTC

Update

We are continuing to investigate this issue.
Posted Mar 15, 2023 - 12:37 UTC

Investigating

There is an issue with our custodial partner who are investigating.
Posted Mar 15, 2023 - 12:34 UTC
This incident affected: Website, Mobile, and Rain Pro.