website rain.com is inacccessible

Incident Report for Rain

Resolved

The website rain.com is restored. It is now accessible
Posted Nov 08, 2022 - 10:15 UTC

Investigating

We are investigating the incident.
Posted Nov 08, 2022 - 10:03 UTC
This incident affected: Website.